PHP Packages Uninstalling PEAR Packages - Web Development and Design | Tutorial for Java, PHP, HTML, Javascript PHP Packages Uninstalling PEAR Packages - Web Development and Design | Tutorial for Java, PHP, HTML, Javascript

Breaking

Post Top Ad

Post Top Ad

Thursday, July 18, 2019

PHP Packages Uninstalling PEAR Packages

PHP Packages



Uninstalling PEAR Packages

Problem

You wish to remove a PEAR package from your system.

Solution

The uninstall command tells the PEAR installer to delete packages:

       % php pyrus.phar uninstall pear/XML_Beautifier
       Pyrus version 2.0.0a4 SHA-1: 72271D92C3AA1FA96DF9606CD538868544609A52
       Using PEAR installation found at /Users/rasmus/lib
       Uninstalled pear.php.net/XML_Beautifier

Discussion

Uninstalling a package removes it completely from your system. If you want to reinstall it, you must begin as if the package was never installed.

If you try to remove a package that another package depends on, Pyrus will warn you and halt the uninstall process. For example, take a look at a sample PEAR installation:

       % sudo php pyrus.phar list-packages
       Pyrus version 2.0.0a4 SHA-1: 72271D92C3AA1FA96DF9606CD538868544609A52
       Using PEAR installation found at /Users/rasmus/lib
       Listing installed packages [/Users/rasmus/lib]:
       [channel pear.php.net]:
       Archive_Tar 1.3.7 stable
       Console_Getopt 1.3.0 stable
       HTTP2 1.1.1 stable
       PEAR 1.9.4 stable
       Structures_Graph 1.0.4 stable
       XML_Beautifier 1.2.1 stable
       XML_Parser 1.3.4 stable
       XML_Parser2 0.1.0 beta
       XML_RSS 1.0.2 stable
       XML_SVG 1.1.0 stable
       XML_Util 1.2.1 stable
       XML_Util2 0.1.0 alpha

Now, try to uninstall the XML_Parser package:

       % php pyrus.phar uninstall pear/XML_Parser
       Pyrus version 2.0.0a4 SHA-1: 72271D92C3AA1FA96DF9606CD538868544609A52
       Using PEAR installation found at /Users/rasmus/lib
       Pyrus\Installer\Exception: Dependency validation failed for some installed
              packages, installation aborted
       Pyrus\Dependency\Exception: channel://pear.php.net/XML_Parser (version >=
              1.0.1, excluded versions: 1.0.1) is required by installed package
              "channel://pear.php.net/XML_RSS"

You can still force a package that has dependencies to uninstall by using the -f flag or --force flag to instruct Pyrus to ignore dependencies and uninstall anyway. Use this capability with caution.

There is no way to automatically roll back an upgrade to an earlier version of a package by using uninstall.

The short command for uninstall is un.

No comments:

Post a Comment

Post Top Ad